Re: [j-nsp] BGP-OSPF route redistribution

From: Denise Sandell (dsandell@voyager.net)
Date: Wed Jun 13 2001 - 21:23:12 EDT


On Mon, Jun 11, 2001 at 04:26:00PM +0200, eedmgu@eed.ericsson.se wrote:
> Hi,
>
> I'm new to Juniper routers, so please forgive me if this is a FAQ (I
> couldn't find anything in the digest):
>
> I'm trying to set up an M40 to redistribute routes from OSPF to BGP,
> exchanging with a Cisco 7507. The M40 sees the routes from the Cisco just
> fine, but the Cisco doesn't receive anything. Is there anything I need
> to do to emulate the Cisco "redistribute ospf <...>" statement?

You need a policy statement to export OSPF routes (kinda similar
to cisco route-maps).

I highly suggest reading the documentation on policy-options for
Junos, as they can cause significant damage to your routing tables
if you're filtering improperly.

links to appropriate documentation:
(https://www.juniper.net/techpubs/software/junos44/swconfig44-routing/frameset.htm)

Policies for exporting OSPF routes can be pretty simple, here's mine

policy-options {
    policy-statement static-ospf-export {
        term 10 {
            from protocol direct;
            then accept;
        }
        term 20 {
            from protocol static;
            then accept;
        }
        then reject;
    }
}

(although this policy not only exports from direct, but from static
routes too.)

and the policy must be stated in your protocol configuration:

protocols {
    ospf {
        export static-ospf-export;
        area 0.0.0.0 {
            interface all {
                passive;
                metric 10000;
            }
            interface fe-6/0/0.0;
            interface at-1/0/0.0;
         }

    }
}

(metrics are also helpful)

I hope this points you in the right direction.

>
> The relevant bits of the configs are below. Thanks in advance for any
> help!
>
> - Markolf
>
> *** Cisco:
>
> interface ATM1/0/0.8 point-to-point
> ip address 192.168.201.225 255.255.255.252
> pvc 100/38
> vbr-nrt 103515 51757 10000
> encapsulation aal5snap
> !
> router bgp 65500
> bgp log-neighbor-changes
> redistribute ospf 100
> [neighbours...]
> neighbor 192.168.201.226 remote-as 64000
> no auto-summary
> !
>
> *** Juniper:
>
> interfaces {
> at-1/0/0 {
> unit 0 {
> encapsulation atm-snap;
> vci 100.38;
> family inet {
> address 192.168.201.226/30;
> }
> }
> }
> fe-6/0/0 {
> unit 0 {
> family inet {
> address 10.0.24.253/24;
> }
> }
> }
> }
> protocols {
> bgp {
> log-updown;
> group 52-72 {
> type external;
> peer-as 65500;
> neighbor 192.168.201.225;
> }
> }
> ospf {
> area 0.0.0.0 {
> interface fe-6/0/0.0;
> interface at-1/0/0.0;
> }
> }
> }
>

-- 
- Denise Sandell                         network operations manager -
- dsandell@voyager.net              voyager.net, a CoreComm company -
- PGP --               http://www.execpc.com/~dsandell/stuff/PGPpub -



This archive was generated by hypermail 2b29 : Mon Aug 05 2002 - 10:42:37 EDT