[j-nsp] R: [j-nsp] BGP-OSPF route redistribution

From: Stefano Bosio (sbosio@inwind.it)
Date: Tue Jun 19 2001 - 08:24:33 EDT


you must use policy-option

policy-options {
    policy-statement ospf-to-bgp {
        term 1 {
            from protocol ospf;
            then accept;
        }
    }
}
protocols {
     ospf {
        export bgp-to-ospf;
        area 0.0.0.0 {
             interface fe-6/0/0.0;
             interface at-1/0/0.0;
        }
    }
}

hope this help

stefano

> -----Messaggio originale-----
> Da: eedmgu@eed.ericsson.se [mailto:eedmgu@eed.ericsson.se]
> Inviato: lunedi 11 giugno 2001 16.26
> A: juniper-nsp@puck.nether.net
> Oggetto: [j-nsp] BGP-OSPF route redistribution
>
>
> Hi,
>
> I'm new to Juniper routers, so please forgive me if this is a FAQ (I
> couldn't find anything in the digest):
>
> I'm trying to set up an M40 to redistribute routes from OSPF to BGP,
> exchanging with a Cisco 7507. The M40 sees the routes from
> the Cisco just
> fine, but the Cisco doesn't receive anything. Is there anything I need
> to do to emulate the Cisco "redistribute ospf <...>" statement?
>
> The relevant bits of the configs are below. Thanks in advance for any
> help!
>
> - Markolf
>
> *** Cisco:
>
> interface ATM1/0/0.8 point-to-point
> ip address 192.168.201.225 255.255.255.252
> pvc 100/38
> vbr-nrt 103515 51757 10000
> encapsulation aal5snap
> !
> router bgp 65500
> bgp log-neighbor-changes
> redistribute ospf 100
> [neighbours...]
> neighbor 192.168.201.226 remote-as 64000
> no auto-summary
> !
>
> *** Juniper:
>
> interfaces {
> at-1/0/0 {
> unit 0 {
> encapsulation atm-snap;
> vci 100.38;
> family inet {
> address 192.168.201.226/30;
> }
> }
> }
> fe-6/0/0 {
> unit 0 {
> family inet {
> address 10.0.24.253/24;
> }
> }
> }
> }
> protocols {
> bgp {
> log-updown;
> group 52-72 {
> type external;
> peer-as 65500;
> neighbor 192.168.201.225;
> }
> }
> ospf {
> area 0.0.0.0 {
> interface fe-6/0/0.0;
> interface at-1/0/0.0;
> }
> }
> }
>
>



This archive was generated by hypermail 2b29 : Mon Aug 05 2002 - 10:42:37 EDT