[nsp] Inbound traffic and two BGP paths

Marcus Keane mkeane@microsoft.com
Thu, 26 Sep 2002 17:51:47 +1000


Tommy, if I understand the requirement correctly, the only way off the
top of my head that I can see to do this is to policy-route traffic
received on the customer interfaces out the respective ATM circuit, and
then just let destination based routing take care of the inbound traffic
from the Internet.
Marcus.


-----Original Message-----
From: TMS [mailto:tomek@absolut.vinyl.pl]=20
Sent: 26 September 2002 16:19
To: cisco-nsp@puck.nether.net
Subject: [nsp] Inbound traffic and two BGP paths


Hello I have question regarding BGP protocol. I have router with two BGP
connections to Tier-1 providers - Sprint and Telia. To this router I
connected also customer which wants two links, first to Sprint and
second for Telia. I created each link using separate BGP session and
separate E1/Serial interface. My question is about inbound traffic from
Sprint and Telia. Is this traffic go to customer through good interface
? Or router do load-balancing between Serial2/0 and Serial2/1 (equal BGP
paths to customer) ? My idea is: traffic from Sprint must return via
Serial2/0 and traffic from Telia must return via Serial2/1.

Router configurtion:

!
interface ATM1/0
	no ip address
!
interface ATM1/0.100
	description Sprint (AS1239)
	bandwidth 10000
	ip address 10.10.10.2 255.255.255.252
	pvc 0/100
		enapsulation aal5snap
		vbr-nrt 10000 10000
	!
!
interface ATM1/0.200
	description Telia (AS1299)
	bandwidth 10000
	ip address 20.20.20.2 255.255.255.252
	pvc 0/200
		enapsulation aal5snap
		vbr-nrt 10000 10000
	!
!
interface Serial2/0
	description Customer (AS200) - Sprint
	bandwidth 1000
	ip address 30.30.30.1 255.255.252
!
interface Serial2/1
	description Customer (AS200) - Telia
	bandwidth 1000
	ip address 40.40.40.1 255.255.252
!
router bgp 100
	network 30.30.30.0 mask 255.255.255.0
	network 40.40.40.0 mask 255.255.255.0
	!
	neighbor 10.10.10.1 description Sprint
	neighbor 10.10.10.1 remote-as 1239
	neighbor 10.10.10.1 filter-list 1 out
	!
	neighbor 20.20.20.1 description Telia
	neighbor 20.20.20.1 remote-as 1299
	neighbor 20.20.20.1 filter-list 1 out
	!
	neighbor 30.30.30.2 descripion Customer - Sprint
	neighbor 30.30.30.2 remote-as 200
	neighbor 30.30.30.2 filter-list 30 out
	neighbor 30.30.30.2 route-map SETLOC in
	!
	neighbor 40.40.40.2 descripion Customer - Telia
	neighbor 40.40.40.2 remote-as 200
	neighbor 40.40.40.2 filter-list 40 out
	neighbor 40.40.40.2 route-map SETLOC in
	!
!
ip as-path access-list 1 permit ^$
ip as-path access-list 30 permit ^1239_
ip as-path access-list 40 permit ^1299_
!
route-map SETLOC permit 10
	set local-preference 1000
	set community 100:1
!

best regards,
Tommy
_______________________________________________
cisco-nsp mailing list  real_name)s@puck.nether.net
http://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/