[c-nsp] adsl config for 827 router

Dan dan at technc.com
Wed Apr 11 19:25:58 EDT 2007


Thanks,

The debug commands helped me out.  It was an authentication problem.  I 
had to change this:

ppp chap hostname nothere
ppp chap password 7 nothere

to this:

ppp authentication chap callin

Dan.

Ian McDonald wrote:
> Dan wrote:
>> Hello,
>>
>> I'm having some trouble with connecting an 827 router to my isp.  I 
>> have tried calling them but they don't seem to want to help.
>>
>> When i'm connected via the console the virtual-access1 interface just 
>> goes up and down and never connects.
>>
>> Building configuration...
>>
>> Current configuration : 2458 bytes
>> !
>> version 12.2
>> no service pad
>> service timestamps debug datetime msec
>> service timestamps log datetime msec
>>
>> ip subnet-zero
>> ip name-server 142.161.130.155
>> ip name-server 142.161.2.155
>> !
>> ip inspect name myfw cuseeme timeout 3600
>> ip inspect name myfw ftp timeout 3600
>> ip inspect name myfw http timeout 3600
>> ip inspect name myfw rcmd timeout 3600
>> ip inspect name myfw realaudio timeout 3600
>> ip inspect name myfw smtp timeout 3600
>> ip inspect name myfw tftp timeout 30
>> ip inspect name myfw udp timeout 15
>> ip inspect name myfw tcp timeout 3600
>> ip inspect name myfw h323 timeout 3600
>> vpdn enable
>> !
>> vpdn-group 1
>>  request-dialin
>>   protocol pppoe
>> !
>> !
>> !
>> !
>> !
>> !
>> !
>> interface Ethernet0
>>  ip address 10.10.50.103 255.255.255.0
>>  ip nat inside
>>  ip tcp adjust-mss 1452
>>  hold-queue 100 out
>> !
>> interface ATM0
>>  no ip address
>>  no atm ilmi-keepalive
>>  bundle-enable
>>  dsl operating-mode auto
>>  hold-queue 224 in
>> !
>> interface ATM0.1 point-to-point
>>  pvc 0/35
>>   pppoe-client dial-pool-number 1
>>  !
>> !
>> interface Dialer1
>>  ip address negotiated
>>  ip mtu 1492
>>  ip nat outside
>>  encapsulation ppp
>>  ip tcp adjust-mss 1452
>>  dialer pool 1
>>  dialer-group 1
>>  ppp authentication pap chap callin
>>  ppp chap hostname ***************
>>  ppp chap password 0 **********
>>  ppp pap sent-username *********** password 0 **********
>> !
>> ip nat inside source list 102 interface Dialer1 overload
>> ip classless
>> ip route 0.0.0.0 0.0.0.0 Dialer1
>> ip http server
>> no ip http secure-server
>> !
>> !
>> access-list 102 permit ip 10.10.50.0 0.0.0.255 any
>> access-list 111 permit icmp any any administratively-prohibited
>> access-list 111 permit icmp any any echo
>> access-list 111 permit icmp any any echo-reply
>> access-list 111 permit icmp any any packet-too-big
>> access-list 111 permit icmp any any time-exceeded
>> access-list 111 permit icmp any any traceroute
>> access-list 111 permit icmp any any unreachable
>> access-list 111 permit udp any eq domain any
>> access-list 111 permit udp any eq bootps any eq bootpc
>> access-list 111 permit udp any eq bootps any eq bootps
>> access-list 111 permit esp any any
>> access-list 111 permit udp any any eq isakmp
>> access-list 111 deny   ip any any
>> dialer-list 1 protocol ip permit
>> !
>> !
>> line con 0
>>  stopbits 1
>> line vty 0 4
>>  exec-timeout 0 0
>>  login local
>>  length 0
>> !
>> scheduler max-task-time 5000
>> end
>>
>> dsl03#
>>
>>
>>  From what I can tell its basically a default config.
>>
>> Thanks,
>> Dan.
>>
>> _______________________________________________
>> cisco-nsp mailing list  cisco-nsp at puck.nether.net
>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>>
>>
> Oh I forgot
>
> debug atm events
> debug ppp authentication
>
> etc
> etc
>
>
> Here's a config from one of my working ones, here in the UK. It 
> appears auto works fine on this one. On 857 and 837, work it doesn't.
>
> !
> version 12.2
> no service pad
> service timestamps debug uptime
> service timestamps log uptime
> service password-encryption
> !
> hostname Router
> !
> enable password 7 nothere
> !
> ip subnet-zero
> ip name-server 158.152.1.58
> ip name-server 158.152.1.43
> ip dhcp excluded-address 10.10.10.1
> !
> ip dhcp pool CLIENT
>    import all
>    network 10.10.10.0 255.255.255.0
>    default-router 10.10.10.1
>    dns-server 158.152.1.58 158.152.1.43
>    lease 0 2
> !
> !
> !
> !
> interface Ethernet0
>  ip address 10.10.10.1 255.255.255.0
>  ip nat inside
>  ip tcp adjust-mss 1452
>  hold-queue 100 out
> !
> interface ATM0
>  no ip address
>  atm vc-per-vp 64
>  no atm ilmi-keepalive
>  pvc 0/38
>   encapsulation aal5mux ppp dialer
>   pppoe-client dial-pool-number 1
>  !
>  dsl operating-mode auto
> !
> interface Dialer1
>  ip address nothere 255.0.0.0
>  ip mtu 1492
>  ip nat outside
>  encapsulation ppp
>  ip tcp adjust-mss 1452
>  dialer pool 1
>  dialer-group 1
>  ppp authentication chap pap callin
>  ppp chap hostname nothere
>  ppp chap password 7 nothere
>  ppp pap sent-username nothere password 7 nothere
>  ppp ipcp dns request
>  ppp ipcp wins request
>  hold-queue 224 in
> !
> ip nat inside source list 102 interface Dialer1 overload
> ip nat inside source static tcp 10.10.10.10 5900 interface Dialer1 5900
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer1
> ip http server
> !
> !
> access-list 23 permit 10.10.10.0 0.0.0.255
> access-list 23 permit nothere 0.0.0.255
> access-list 23 permit nothere 0.0.0.255
> access-list 102 permit ip 10.10.10.0 0.0.0.255 any
> access-list 102 permit tcp any any eq 5900
> dialer-list 1 protocol ip permit
> !
> line con 0
>  exec-timeout 120 0
>  stopbits 1
> line vty 0 4
>  access-class 23 in
>  exec-timeout 120 0
>  password 7 nothere
>  login
>  length 0
> !
> scheduler max-task-time 5000
> end
>




More information about the cisco-nsp mailing list