[c-nsp] Need pointers for configuring NAT on 1841

Jason Berenson jason at pins.net
Wed Sep 3 16:36:47 EDT 2008


Scott,

I believe you will need a public /30 if you want to do NAT on the 
Cisco.  Your dialer would be the "ip nat outside" and the ethernet 
connection with all the 192.168.x.y/24 addresses would be the "ip nat 
inside" interface.

This should take care of outbound NAT:

ip nat inside source list 1 interface dialer1 overload
access-list 1 permit 192.168.1.0 0.0.0.255

This should take care of any inbound ports you want to open:

ip nat inside source static udp 192.168.x.y 5060 interface dialer1 5060

-Jason

Scott Granados wrote:
> I have a DSL loop provisioned as follows.  Via PPPOE I'm assigned a 
> /30 that's allocated from unrouted addresses.  I then am routed a 
> public pool /29 in length via the /30.
>
> I'm using a Cisco 1841 with a WIC-1-ADSL card and 2 ethernet ports.  
> On one of the LAN ports I have the /29.  (This works)  I'd like to set 
> up nat on the other LAN port and I would assume that I would use one 
> of my addresses from my /29 for the translation.  I have the following 
> config but can't figure out the NAT portion to add or find good 
> examples via google.  Any pointers would be appreciated or better 
> still a pointer that could take me through the fundimentals (assuming 
> my config will work at all).
>
> Thank you
> Scott
>
> ip dhcp pool lan
>
>   network 192.168.13.0 255.255.255.0
>
>   default-router 192.168.13.1
> !
>
> multilink bundle-name authenticated
>
> vpdn enable
>
> !
>
> vpdn-group 1
>
> request-dialin
>
>  protocol pppoe
>
> l2tp tunnel receive-window 1024
>
>
> bba-group pppoe global
>
> !
>
> !
>
> interface FastEthernet0/0
>
> ip address 192.168.13.1 255.255.255.0
>
> duplex auto
>
> speed auto
>
> !
>
> interface FastEthernet0/1
>
> ip address x.x.x.1 255.255.255.248
>
> duplex auto
>
> speed auto
>
> !
>
> interface ATM0/0/0
>
> no ip address
>
> no atm ilmi-keepalive
>
> dsl operating-mode auto
>
> dsl enable-training-log
>
> pvc 0/35
>
>  encapsulation aal5snap
>
>  pppoe-client dial-pool-number 1
>
> !
>
> interface Dialer1
>
> ip address negotiated
>
> ip mtu 1492
>
> encapsulation ppp
>
> no ip mroute-cache
>
> dialer pool 1
>
> dialer-group 1
>
> ppp authentication chap callin
>
> ppp chap hostname "YourNameHere at bz8"
>
> ppp chap password 0 "YourPassWord"
>
> !
>
> ip route 0.0.0.0 0.0.0.0 Dialer1
>
> !
>
>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/


More information about the cisco-nsp mailing list