[c-nsp] Simple src/dst IP QoS

Ray Davis ray-lists at carpe.net
Fri Dec 17 10:34:29 EST 2010


After reading the article I mentioned further I changed the config to...

     class-map match-all voice-sig
      match protocol sip
     class-map match-all voice-rtp
      match protocol rtp

     policy-map PrioritizeVoice
      class voice-rtp
         priority percent 33
      class voice-sig
         priority percent 20
      class class-default
     policy-map Shaper6.4M   
      class class-default
         random-detect
         shape average 6400000 160000 160000
       service-policy PrioritizeVoice
    
     interface FastEthernet0/0
      description Inside Customer LAN-1 (linknet to ASA firewall)
      load-interval 30
      service-policy output Shaper6.4M

     interface Dialer1
      description pppoe multilink Dialer (SHDSL line)
      load-interval 30
      service-policy output Shaper6.4M 

It's better, but not perfect yet.  Perhaps I need to figure out how to implement something similar on the ASA behind the IOS router.

Cheers,
Ray

On 17. Dec 2010, at 15:39 Uhr, Ray Davis wrote:

> The DSL side is the Dialer interface which has "bandwidth 4608" in it's config.  I don't know if service-policy pays any attention to that or not.  The LAN side has no bandwidth statement.
> 
> Would I be better off doing something like this?
> 
>     class-map match-all voice-sig
>      match protocol sip
>     class-map match-all voice-rtp
>      match protocol rtp
> 
>     policy-map PrioritizeVoice
>      class voice-rtp
>         priority percent 33
>      class voice-sig
>         priority percent 20
>      class class-default
>     policy-map Shaper6.4M
>      class class-default
>         shape average 6400000
>       service-policy PrioritizeVoice
> 
>     interface FastEthernet0/0
>      description Inside Customer LAN-1 (linknet to ASA firewall)
>      load-interval 30
>      service-policy output Shaper6.4M
> 
>     interface Dialer1
>      description pppoe multilink Dialer (SHDSL line)
>      load-interval 30
>      service-policy output Shaper6.4M
> 
> And should I be shaping on both the LAN & WAN side?
> 
> Thanks,
> Ray
> 
> PS: FYI, I copied the above from http://inetpro.org/wiki/HQoS
> 
> On 17. Dec 2010, at 15:15 Uhr, David Prall wrote:
> 
>> You'll need to do an HQoS shaper on the inside fastethernet interface in
>> order to shape remote traffic so that they fall back. You're giving 50
>> percent priority to a 4.6Mbps link, on a 100Mbps interface or have you
>> configured the correct bandwidth statement on it. I've found using HQoS
>> tends to fix things to a point.
>> 
>> David
>> 
>> --
>> http://dcp.dcptech.com
>> 
>> 
>>> -----Original Message-----
>>> From: cisco-nsp-bounces at puck.nether.net [mailto:cisco-nsp-
>>> bounces at puck.nether.net] On Behalf Of Ray Davis
>>> Sent: Friday, December 17, 2010 8:18 AM
>>> To: Cisco-nsp
>>> Subject: [c-nsp] Simple src/dst IP QoS
>>> 
>>> Hi,
>>> 
>>> A customer with a 4.6 Mbit SHDSL line has a remote voip proxy - and
>>> gets drops & jitter when putting load on the line.  Instead of trying
>>> to identify voip traffic by protocol and/or ef bits, I tried via the
>>> voip proxy IP address.  Is there any reason why this wouldn't work in
>>> IOS (1841, 12.4)?
>>> 
>>>   class-map match-any VoipTraffic
>>>    match access-group name VoipHost
>>> 
>>>   ip access-list extended VoipHost
>>>    permit ip any host 123.456.123.456
>>>    permit ip host 123.456.123.456 any
>>> 
>>>   policy-map VoipPolicy
>>>    class VoipTraffic
>>>       priority percent 50
>>>    class class-default
>>>       fair-queue
>>> 
>>>   interface FastEthernet0/0
>>>    description Inside Customer LAN-1 (linknet to ASA firewall)
>>>    service-policy output VoipPolicy
>>> 
>>>   interface Dialer1
>>>    description pppoe multilink Dialer (SHDSL line)
>>>    bandwidth 4608
>>>    service-policy output VoipPolicy
>>> 
>>> 
>>> The LAC on the other end has something similar ...
>>> 
>>>   class-map match-any VoipServersTraffic
>>>    match access-group name VoipServers
>>> 
>>>   ip access-list extended VoipServers
>>>    permit ip any host 123.456.123.456
>>>    permit ip host 123.456.123.456 any
>>>    permit ip any host 100.200.300.400
>>>    permit ip host 100.200.300.400 any
>>>    permit ip any host 321.1.2.3
>>>    permit ip host 321.1.2.3 any
>>> 
>>>   policy-map VoipServersPolicy
>>>    class VoipServersTraffic
>>>     priority percent 50
>>>    class class-default
>>>     fair-queue
>>> 
>>>   interface Virtual-Template2
>>>    service-policy output VoipServersPolicy
>>> 
>>>   interface FastEthernet0/0
>>>    description NAP local ethernet
>>>    service-policy output VoipServersPolicy
>>> 
>>> If so, then any suggestions?  The customer still get drops when the
>>> line is saturated with other traffic.  Perhaps a different "priority"
>>> type?  or something totally different?
>>> 
>>> Thanks,
>>> Ray
>>> _______________________________________________
>>> cisco-nsp mailing list  cisco-nsp at puck.nether.net
>>> https://puck.nether.net/mailman/listinfo/cisco-nsp
>>> archive at http://puck.nether.net/pipermail/cisco-nsp/
>> 
> 
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/




More information about the cisco-nsp mailing list