[f-nsp] Multicasting config example?

Marcus Eide marcus at conf.se
Tue Feb 24 02:28:58 EST 2009


I can recommend PIM-SM w. static RP, MSDP and M-BGP in a routed
envrionment. It's pretty straight forward:

interface loopback 2
 ip address 1.1.1.1 <- Use this as rp-address in all routers
 ip pim-sparse
 ...
!
vlan 10 name mcast
 untagged e 1/2
 router-interface ve 10
!
interface e1/1
 port-name to R2
 ip address x.x.x.x
 ip pim-sparse
 ...
!
interface ve 10
 port-name "mcast sender"
 ip address 192.168.0.0/24
 ip pim-sparse <- this enables IGMP too
 ...
!
router pim
 rp-address 1.1.1.1 <- RP-address
!
router msdp
 msdp peer 1.1.1.2 <- Router 2's loopback
 msdp peer 1.1.1.3 <- Router 3's loopback
!
router bgp
 ...
 address-family ipv4 multicast
 network 192.168.0.0/24
 neighbor 1.1.1.2 activate
 neighbor 1.1.1.3 activate
!

/Marcus

On Mon, 23 Feb 2009 21:45:39 +0100, Bjørn Skovlund Rydén
<BSR at fullrate.dk>
wrote:
> Hi everyone,
> 
> Sorry to bother you for this, but my technical friend at Foundry seems to
> have gone on vacation for a few weeks, and I'd like to get on with this.
> 
> We're running a mesh of 6 MLX's with distribution rings based on
FES/FESX.
> I'm now starting to look at multicasting and having read back and forth
in
> the config-guide, I'm still a bit clueless as to how to get the simplest
> thing to work.
> 
> I would like to receive multicast traffic on a VLAN on MLX A and have
> recipient on MLX B on a routed interface. Very basic stuff, I'd say, but
> after a day in the test-lab, I'm still not successful :( So can someone
> give me the most basic configuration example on how to do this?
> 
> Kind regards,
> Bjørn



More information about the foundry-nsp mailing list