[j-nsp] Logical Routers intercommunication?
Marlon Duksa
mduksa at gmail.com
Fri Aug 1 10:57:43 EDT 2008
Yes, they are connected via external intf. I'm actually monitoring this link
via wireshark and I only see BGP keepalives going through. This issue is
hard to notice if you are not sniffing the wire...
Here is the config. Thanks.
admin at re-0# show
## Last changed: 2008-07-31 21:21:28 PDT
version 9.1R2.10;
groups {
re0 {
system {
host-name re-0;
}
interfaces {
fxp0 {
unit 0 {
family inet {
address 172.22.34.82/25;
address 172.22.34.84/25 {
master-only;
}
}
}
}
}
}
re1 {
system {
host-name re-1;
}
interfaces {
fxp0 {
unit 0 {
family inet {
address 172.22.34.83/25;
address 172.22.34.84/25 {
master-only;
}
}
}
}
}
}
}
apply-groups [ re0 re1 ];
system {
backup-router 172.22.184.1 destination 128.251.10.124/32;
time-zone America/Los_Angeles;
root-authentication {
encrypted-password "$1$OBAWMlCT$MuNLaDG0UGv4VhSe2hOmC/"; ##
SECRET-DATA
}
login {
user admin {
uid 2000;
class superuser;
authentication {
encrypted-password "$1$PfxKMPof$fGFscYkmB.Eq0lkYBNvqu/"; ##
SECRET-DATA
}
}
}
services {
telnet;
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
}
commit synchronize;
ntp {
server 128.251.10.19;
}
}
logical-routers {
LR1 {
interfaces {
ge-1/0/0 {
unit 0;
}
ge-3/0/0 {
unit 0 {
family inet {
address 10.0.2.2/24;
}
family mpls;
}
}
ge-5/0/3 {
unit 0 {
family inet {
address 10.0.1.1/24;
}
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 2.2.2.2/32;
}
}
}
}
protocols {
mpls {
interface ge-5/0/3.0;
interface ge-3/0/0.0;
interface lo0.0;
}
bgp {
group vpls {
type internal;
traceoptions {
file bgp.trc size 10m;
flag all detail;
}
local-address 2.2.2.2;
family l2vpn {
signaling;
}
neighbor 1.1.1.1;
neighbor 3.3.3.3;
}
}
ospf {
area 0.0.0.0 {
interface lo0.0;
interface ge-5/0/3.0;
interface ge-3/0/0.0;
}
}
ldp {
interface ge-3/0/0.0;
interface ge-5/0/3.0;
interface lo0.0;
}
}
routing-instances {
vpls {
instance-type vpls;
interface ge-1/0/0.0;
route-distinguisher 100:200;
vrf-target target:200:200;
protocols {
vpls {
traceoptions {
file vpls.trc size 10m;
flag all detail;
}
site-range 10;
site multi {
site-identifier 4;
multi-homing;
site-preference 100;
interface ge-1/0/0.0;
}
}
}
}
}
routing-options {
router-id 2.2.2.2;
autonomous-system 100;
}
}
LR2 {
interfaces {
ge-3/0/4 {
unit 0 {
family inet {
address 10.0.1.2/24;
}
family mpls;
}
}
ge-3/0/5 {
unit 0;
}
ge-5/0/4 {
unit 0;
}
ge-5/0/7 {
unit 0 {
family inet {
address 10.0.0.2/24;
}
family mpls;
}
}
lo0 {
unit 1 {
family inet {
address 3.3.3.3/32;
}
}
}
}
protocols {
mpls {
interface ge-5/0/7.0;
interface ge-3/0/4.0;
interface lo0.1;
}
bgp {
group vpls {
type internal;
traceoptions {
file bgp.trc size 10m;
flag all detail;
}
local-address 3.3.3.3;
family l2vpn {
signaling;
}
neighbor 1.1.1.1;
neighbor 2.2.2.2;
}
}
ospf {
area 0.0.0.0 {
interface lo0.1;
interface ge-5/0/7.0;
interface ge-3/0/4.0;
}
}
ldp {
interface ge-3/0/4.0;
interface ge-5/0/7.0;
interface lo0.1;
}
}
routing-instances {
vpls {
instance-type vpls;
interface ge-5/0/4.0;
interface ge-3/0/5.0;
route-distinguisher 100:300;
vrf-target target:200:200;
protocols {
vpls {
traceoptions {
file vpls.trc size 10m;
flag all detail;
}
site-range 10;
site green {
site-identifier 3;
interface ge-5/0/4.0;
interface ge-3/0/5.0;
}
}
}
}
}
routing-options {
router-id 3.3.3.3;
autonomous-system 100;
}
}
}
chassis {
redundancy {
routing-engine 0 master;
graceful-switchover;
}
}
interfaces {
ge-1/0/0 {
encapsulation ethernet-vpls;
}
ge-3/0/2 {
encapsulation ethernet-vpls;
}
ge-3/0/5 {
encapsulation ethernet-vpls;
}
ge-5/0/0 {
encapsulation ethernet-vpls;
}
ge-5/0/4 {
encapsulation ethernet-vpls;
}
fxp0 {
unit 0 {
family inet;
}
}
}
routing-options {
static {
route 128.251.0.0/16 next-hop 172.22.34.1;
route 192.168.0.0/16 next-hop 172.22.34.1;
route 172.22.0.0/16 next-hop 172.22.34.1;
}
}
{master}[edit]
admin at re-0#
On Fri, Aug 1, 2008 at 7:26 AM, <alain.briant at bt.com> wrote:
> I am sure that what you're trying to do is working on Little M series (M7i
> M10i ...)
>
> I have made a lot of tests this way also using some I-BGP or E-BGP between
> the logical routers.
>
> Are you sure your two logical routers are interconnected via external
> interfaces or subinterfaces?
>
> Do you have a summary of your config?
>
> Regards
> Alain
>
>
> -----Message d'origine-----
> De : juniper-nsp-bounces at puck.nether.net [mailto:
> juniper-nsp-bounces at puck.nether.net] De la part de Marlon Duksa
> Envoyé : vendredi 1 août 2008 16:17
> À : juniper-nsp at puck.nether.net
> Objet : [j-nsp] Logical Routers intercommunication?
>
> I have partitioned M320 into two logical routers (LR), and I run MP-BGP
> between them. Those two routers are connected through an external GiGE
> interface. The problem is that BGP UPDATE and OPEN message between them are
> not sent over the external link but instead through some interprocess
> communication. Only keepalives are sent througn the external links.
>
> Like those two logical routers know they are on the same box (which they
> shouldn't).
> Is there any way to disable this inter-router communcation and send all BGP
> mesages through the exteranl links?
> Thanks,
> Marlon
> _______________________________________________
> juniper-nsp mailing list juniper-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
>
More information about the juniper-nsp
mailing list