[j-nsp] JunosE PPPOE Configuration Problem

Paul Stewart paul at paulstewart.org
Fri Sep 16 15:58:05 EDT 2011

Solved this - downgraded JunosE version and all working now!

If you run across this and want details, please see my blog post at



-----Original Message-----
From: juniper-nsp-bounces at puck.nether.net
[mailto:juniper-nsp-bounces at puck.nether.net] On Behalf Of Paul Stewart
Sent: Friday, September 09, 2011 3:12 PM
To: 'Thiago Lizardo de Moraes'
Cc: juniper-nsp at puck.nether.net
Subject: Re: [j-nsp] JunosE PPPOE Configuration Problem

Thank you


I tried that again just in case but no success.  It’s strange how it works
with dynamic IP subscribers and not static IP subscribers as we don’t have
it in our Radius configuration at all.  Having said that, dynamic IP’s are
assigned directly by the ERX and static IP customers are assigned via Framed
IP attribute in Radius.  On our Cisco platforms we added IPCP options that
always worked regarding of dynamic/static assignment.


profile test

ip virtual-router default

ip unnumbered loopback 0

ip mtu 1492

ip sa-validate

ip tcp adjust-mss 1460

ppp authentication virtual-router default pap

ppp keepalive 120

ppp fragmentation

ppp reassembly

vlan auto-configure pppoe


virtual-router default

aaa authentication atm1483 default radius

aaa accounting atm1483 default radius

aaa authentication ip default radius

aaa accounting ip default radius

aaa authentication ipsec default radius

aaa accounting ipsec default radius

aaa dns primary

aaa dns secondary

aaa user accounting interval 10

aaa authentication ppp default radius

aaa accounting ppp default radius


Authentication/Accounting are working perfectly as are the dynamic/static IP
assignments – it’s just the lack of DNS assignment for static IP subscribers
that is puzzling me


Take care,





From: Thiago Lizardo de Moraes [mailto:thilizardo at gmail.com]
Sent: Friday, September 09, 2011 3:05 PM
To: Paul Stewart
Cc: juniper-nsp at puck.nether.net
Subject: Re: [j-nsp] JunosE PPPOE Configuration Problem


Hi Paul,


You can use this config: "aaa dns primary <DNS server IP>"

Best Regards,

Thiago Lizardo de Moraes

2011/9/9 Paul Stewart <paul at paulstewart.org>

Hi folks.

Working on a lab configuration with an ERX box.  When a PPPOE user connects
and has  dynamic assignment, they get all attributes they require (ie. DNS

When we do a static IP assignment to a username, they get no DNS
assignments.  In the Cisco world, this was configured via the IPCP options
and pushed down.

In the ERX configuration I tried to add "ppp ipcp prompt-option dns" under
the default profile (which is what we're using at the moment) and this
didn't solve the issue.

Is that the way that command is supposed to work?

Is there a way to have the ERX push down a specific DNS configuration when a
user connections (which works on dynamic accounts) or do you have to assign
the DNS via Radius attributes on static IP customers?

Thanks very much,


juniper-nsp mailing list juniper-nsp at puck.nether.net

Thiago Lizardo de Moraes
Consultor Técnico
+55 41 8817 5563

juniper-nsp mailing list juniper-nsp at puck.nether.net

More information about the juniper-nsp mailing list